Building errors


I tried to re-implement the vtkMPUReconstruction using the slicer3D. The 3D Slicer is compiled without errors. but when I compile the method I get errors like this:

LNK2001 unresolved external symbol “public: virtual void __cdeclImplicitFunction::asignValueToVoxels (float * * * &,bool * * * &,float * const,float * const,int * const)” ( asignValueToVoxels@ImplicitFunction@@UEAAXAEAPEAPEAPEAMAEAPEAPEAPEA_NQEAM2QEAH@Z)vtkSlicerReconstructionModuleLogic C:\visumedicalB\Reconstruction\Logic\vtkContoursImplicit.obj

and other errors which are similar.

I used visual studio 2015 to compile the 3d slicer and implement the medthod . are there any lib or include directory that i must add to the project?

Thank’s in advance for your help

Probably the best place to start is to generate a Slicer Extension to get the cmake structure you need.

that is exactly what I did. i tried to implement a non optimized marching cube but I get a good results.

I do not understand where is the probleme ? Are there any slicer 3D libs or includes that i must add in my project ? because in generally The error of "unresolved external symbol " usually cause by complier can not find the lib files

Could it be as simple as the typo in the method name? Should have two 's’s: assignValueToVoxels