Depth peeling not working on vtk.js 25

so ive been using vtk for a while now on python and c++ and when i want to render an actor who has both opaque and translucent surfaces, i create a lookup table with its respective RGBA values and turn on depth peeling to avoid having all the actor translucent.
i tried to do the same with vtk.js and everything worked fine except even when i set depth peeling on, alpha blending is still used instead and the entire geometry is translucent. Is depth peeling not enabled the same way as in python/c++ or am i missing something else ?

The current OIT implementation in vtk.js is not depth peeling. It’s a faster approximation, but unfortunately has issues with actors with opaque and translucent surfaces. FYI @finetjul

thank you fro you answer.
is there any alternative approach that can more or less give me the result im looking for ?

Split your actor in 2 actors: one for opaque, one for translucent.

i dont know how i never thought of that, i just tried it and it works like a charm. thank you.