how to get a "thick" poly line from vtkPlaneCutter & vtkPolyData?

I am trying to cut a mesh with a plane and render the contour on top of an image (resliced along using the same plane), much like the image below:

The examples at https://gitlab.kitware.com/vtk/vtk/-/blob/v9.1.0/Filters/Core/Testing/Python/TestPolyDataPlaneCutter.py almost do the slicing part that I need
But when viewing the contour from the direction of the normal the contour / polyline is invisible (see screenshot below left side) as opposed to viewing it from the side (right side of the screenshot below)

So I assume I should try to “dilate” the resulting contour somehow? Any suggestions?

It seems that you need to turn off shading. You can somehow do so by setting 100% ambient color to your contour actor.