In volume rendering, how to set the rendering result to not blur when rotating the camera

The question is what I want to ask


What mapper are you using? vtkSmartVolumeMapper? That blur while dragging is a kind of optimization to trade rendering quality for smooth/high FPS during user interaction.



I use vtkGPUVolumeRayCastMapper

I want to provide users with a set of options, and if their devices are good enough, even if they are not blurry, fps is still sufficient

I think you can call AutoAdjustSampleDistancesOff() on the mapper to turn off the automatic adjustment of raycasting sampling distance, then either call LockSampleDistanceToInputSpacingOn() to lock the sampling distance to the input data spacing, or set the sampling distance manually with SetSampleDistance(…).

1 Like

thank you very much