vtkNew already has move semantics - see vtkNew and vtkSmartPointer, so you don’t get simplified syntax with std::unique_ptr.
I understand that developers don’t want to learn new things if it is not necessary. However, in this case the slightly different syntax is used for a good reason: to clearly differentiate objects that use internal reference counting. Trying to cover this up to ease the burden on developers seems to be a step in the wrong direction, as developers may make wrong decisions if they are not aware how things actually work.