vtk gitlab repo unreachable - just for me

I would like know if anybody else had and managed to solve the same issue. For some reason, the gitlab kitware website is unreachable using my homes internet. The website is definitely not down since isItDownOrJustMe website can reach it and I can reach the gitlab website using my cellphone’s 4G internet. But I am not sure what’s wrong with my home’s internet. I tried to flush my dns and switch dns server but it didn’t work.

On an unrelated note, I wanted to make a pull request to add liblzma to the list of names cmake searches for in FindLZMA.cmake but I am unable to clone the gitlab repository :sweat_smile:

I had a talk with my ISP technician. From his probing around, it seems my IP address is being blocked by gitlab.kitware.com . Since the internet is supplied by my building as part of my rent, they set it up so that the entire building shares the same IP. The last time he saw something like it was when a bank black listed a whole building due to a cyber attack that originated from it. Is there a webmaster I can contact so that I can ask if my IP is being blocked by the firewall?

@cory.quammen : do you know who this should be forwarded to ?

Could you share the IP address in question? Private message to me is okay.

Yes, of course. I will send you a private message.

Hi @marcwang, your IP address was added to a spam blacklist at the end of April, however, it should no longer be blocked. Give it a try again and see if you can access gitlab.kitware.com.

Just tried it, it works now. Thank you Cory !