CMAKE Generation issue in Ubuntu

I am having trouble generating cmake files in ubuntu.
Can someone help with the Compatibility metrics of the various vtx versions
VTK Version G++ version Cmake Version

  • 9 -----------?-----------------------?

  • 8 -----------?-----------------------?

  • 6.3 -----------?-----------------------?

What are you trying to generate? I know that VTK 6.3 doesn’t support GCC 9+ due to some silly compiler detection routines, I forget about VTK 8, and 9 supports whatever CMake ends up detecting.

I just wanted to run CMAKE so that i can build a C++ project to generate the .so files of VTK . I am using
CMAKE 3.20.2 with Unix MakeFiles
G++ 9.3
and I have tried vtx 9.0 and 8.2

for 9.0 i have the following error:
Could NOT find X11 (missing: Xt)
CMake Error at CMake/vtkModule.cmake:4140 (message):
Could not find the X11 external dependency.
Call Stack (most recent call first):
Rendering/OpenGL2/CMakeLists.txt:334 (vtk_module_find_package)

and i have tried ```
sudo apt-get install libx11-dev

to resolve but without any success

sudo apt-get install libxt-dev

I also see this posting with the same question. And yes, libx11-dev would not contain libXt; that would be libxt-dev as said above.

1 Like