CMakeLists Doesn't Find Version


I am trying to compile VTK through CMake on Windows. I keep getting this error:

"CMake Error at CMakeLists.txt:18 (include):
include could not find requested file:


CMake Error at CMakeLists.txt:19 (include):
include could not find requested file:


CMake Error at CMakeLists.txt:22 (determine_version):
Unknown CMake command “determine_version”.

Does anyone have a solution for this?

What version of VTK? Where did you get the source from?

Version 9.1.0. I got the source from the VTK website download page.

The source tarball has these files. Could you please give specific instructions for what led to these errors?

I created a source folder that had VTK 9.1.0 in it and then I created a build folder. When I run CMake it works until it hits the CMakelist error I listed above.

The source I downloaded here worked just fine. Do you have specific commands I could run to reproduce the behavior (including downloading and extracting the source)?

Hello! I ended up reinstalling VTK and the problem resolved itself. I believe that during installation, it must not have downloaded all of the files. Thank you for your help!