Cylinder Demo bugs in ver 8.2.0 on Fedora 32 with NVidia hardware

I have a problem getting the Cylinder demo program to work properly on Fedora 32, with NVidia drviers. However, to do something similar in ParaView 5.8 works just fine.

Hi, David,

Can you post an image of what you are getting?



Hi there, sorry for not responding sooner

Here’s a picture showing a broken render of the Cylinder demo, and even include errors in the terminal window.

David, g’day,

The first thing to check when we face rendering problems is to make sure you have the latest graphics drivers installed. A question: is that example supposed to have translucent (alpha blending) surfaces?



It was supposed to be the Cylinder example code. I’ve run it successfully with Nouveau drivers at it works fine. Trueth be told, the working on the NVidia Linux drivers page is a little odd. Their “Production Branch” is at ver. 460.56, while their “New Features” branch is at 455.45. I have been using the New Features Branch, not Production. I will see about upgrding and see if it goes away.

OK, just upgraded to the latest ver. 460. Still happening. The HW is a GeForce GT 730 card.

Ok, is that example supposed to have translucent (alpha blending) surfaces?



If the OpenGL driver is causing problems, then make sure that your window manager is not using OpenGL for compositing. With buggy drivers, problems can occur when multiple processes are using OpenGL at the same time.

My window manager is xfwm4. I just greped through the output of “ps aux” for “compiz” and found only the grep command itself.

I found part of the following command:

for pid in $(ls -d /proc/[0-9]* | cut -d’/’ -f 3)
do sudo lsof -p ${pid} 2> /dev/null | grep /dev/dri

here “” I found that I have 3 processes trying to access the following device on my system: “/dev/dri/renderD128”. The programs that are accessing this seem rather basic, such as (much to my surprise) “xfwm4”, and “Xorg” itself. Any ideas? Thank you very much in advance.

That snippet is useful, I didn’t know how to check driver usage before.

For xfce desktop, if you go to “Desktop Settings” in the “Settings” menu, you should be able to choose xfwm4 without compositing. Xorg has to load the glx module in order for you to use OpenGL with X, so that’s probably why Xorg touches the driver.

I found a way to stop xfwm4 from using OpenGL in “Window Manager Tweaks > Compositor”, but thanks. Still have XOrg using OpenGL though.