Disable transparency when using 2 renderers

I have two renderers, one to visualise the blocks as seen below

and another one to visualise the floor as below

It seems that transparency is causing the floor to show above the blocks.
Is there any advice on this issue please?

Many thanks

If you want to render semi-transparent surfaces correctly then you need to make sure triangles are ordered by depth. The simplest way to achieve that is to enable depth peeling in your renderer. Of course, you must add all your actors to a single renderer.

Thank you @lassoan. I checked the depth peeling recommendations prior to submitting this question but the issue here is that in my architecture I need to separate two scenes, hence, two renderers. Changing the order of layers improves things but is not perfect. Any further advice would be great!