Documentation install for Utilities/Doxygen problem wiht 9.1.0

I built Vtk version 9.1.0 with Docs on. When I try to do the “make install” everything up to the following point installs, then the install breaks:

CMake Error at Utilities/Doxygen/cmake_install.cmake:80 (file):
file INSTALL cannot find
No such file or directory.
Call Stack (most recent call first):
cmake_install.cmake:1119 (include)

There is no doc directory under Utilities/Doxygen

I’m guessing that either the CMake build is messed up or I missed a configuration option.

Can one of the developers shed some light on this issue?

Not sure if the omission of Doxygen target from all is intended but you can compile the Documentation by running

make DoxygenDoc

make install should then work as expected.

It is intended because it is never “clean” and runs on every build.

1 Like

This started to work and then it appears to have put itself into an infinite loop. After 20 minutes I did a control-C to reach the following:

QGDict::hashAsciiKey: Invalid null key
QGDict::hashAsciiKey: Invalid null key^Cmake[3]: *** [Utilities/Doxygen/CMakeFiles/DoxygenDoc] Interrupt
make[2]: *** [Utilities/Doxygen/CMakeFiles/DoxygenDoc.dir/all] Interrupt
make[1]: *** [Utilities/Doxygen/CMakeFiles/DoxygenDoc.dir/rule] Interrupt
make: *** [DoxygenDoc] Interrupt

QGDict::hashAsciiKey: Invalid null key

Possible doxygen bug ?

I tried with doxygen versions 1.8.17 and 1.9.1 and worked as expected.

I’m using version 1.8.5. Will see about updating to something newer. May take a few days.

Ok let me know if you have any further problems. By the way, official (binary) releases for doxygen can be found here