Does VTK support wsl?

I’ve installed VTK 8.2.0 in WSL 2. But when I tried to run an example, it showed:

ERROR: In /mnt/d/Toolkits/VTK-8.2.0/Rendering/OpenGL2/vtkOpenGLRenderWindow.cxx, line 747
vtkXOpenGLRenderWindow (0x55d2f37462f0): Unable to find a valid OpenGL 3.2 or later implementation. Please update your video card driver to the latest version. If you are using Mesa please make sure you have version 11.2 or later and make sure your driver in Mesa supports OpenGL 3.2 such as llvmpipe or openswr. If you are on windows and using Microsoft remote desktop note that it only supports OpenGL 3.2 with nvidia quadro cards. You can use other remoting software such as nomachine to avoid this issue.

Has anyone encountered this problem or known how to solve this problem?

I use VcXsrv + WSL.
turn off “Native opengl” option can solve this problem

1 Like

Did you build VTK with EGL or OSMesa? Without these you can’t start an opengl context without a window/desktop. X server is always an option as well.

Thanks a lot !!

I was stuck for using vtk in wsl for this error, and this small modification solved it for me (in addition to untick this box)


I build vtk with opengl2 and i have the same problem , so can you figure out how can I find the problems ? I think this problems is in compile part ,but I don’t know how to fix this .