git lfs problem

Until 24 Sept I have been able to upload images to vtk-examples with no problems.

Now I am getting this message:

Uploading LFS objects: 100% (6/6), 678 KB | 0 B/s, done.
Enumerating objects: 27, done.
Counting objects: 100% (27/27), done.
Delta compression using up to 12 threads
Compressing objects: 100% (14/14), done.
Writing objects: 100% (14/14), 1.55 KiB | 795.00 KiB/s, done.
Total 14 (delta 5), reused 0 (delta 0), pack-reused 0
remote: GitLab: LFS objects are missing. Ensure LFS is properly set up or try a manual "git lfs push --all".
 ! [remote rejected]         Add_ImageProcessing_Images -> Add_ImageProcessing_Images (pre-receive hook declined)
error: failed to push some refs to ''

I first noticed this when I tried to submit a merge request around 03:00UTC 25 Sept.

Has something changed in the GitLab LFS setup?

I have tried this using both Linux and Windows so I am sure the problem is not at my end.

Thanks in advance for any help.

@mwestphal It has been a few days now since 24Sept and I am still unable to upload LFS objects. I have a suspicion that LFS is not properly set up on the server since it was working for me before 25 Sept and nothing has changed on my machines. Is it possible to get someone to verify that I have the correct permissions etc and that Git LFS is correctly set up?
I am building up a big store of deleted/updated/new images!


I’ve just cloned and got the LFS data successfully.

Ok I’ll try that tomorrow, I have been forking it. Thanks.

Andrew Maclean

Using a clone instead of a fork worked, I just merged these changes to the test images: 102 files changed, 120 insertions(+), 246 deletions(-).


I wonder why the forking approach suddenly failed with git lfs.