GUISupportQtOpenGL

GUISupportQtOpenGL

hi. i installed QT5.14.1 (VS 2015 ) with QT offline installer before compiling VTK unstable, but an error occurred. i used vtk-unstable, VS2015(update 1) , cmake 3.16.4 and QT5.14.1( VS 2015) . i used VTK unstable because i need VtkCollisionDetectionFilter. qt options in cmake:

VTK_BUILD_QT_DESIGNER_PLUGIN : checked 
VTK_GROUP_ENABLE_Qt= yes 
VTK_MODULE_ENABLE_VTK_GUISupportQt= want 
VTK_MODULE_ENABLE_VTK_GUISupportQtOpenGL=want 
VTK_MODULE_ENABLE_VTK_GUISupportQtSQL = want 
VTK_MODULE_ENABLE_VTK_RenderingQt = want 
VTK_MODULE_ENABLE_VTK_ViewsQt= want

Error C2039 ‘Frame’: is not a member of ‘QGLWidget’ GUISupportQtOpen how can i solve this error.

Can you copy the full error ?

hi Mathieu . thanks for your answer.

Error C2039 'Frame': is not a member of 'QGLWidget' GUISupportQtOpenGL C:\VTK\SOURCE\source\GUISupport\QtOpenGL\QVTKWidget2.cxx 488

I don’t see this code in the last version of the code containing QVTKWidget2.

A few questions :

  • Why are you compiling GUISupportQtOpenGL ? It is a deprecated module that actually has just been removed from master.
  • What is vtk-unstable ?