How to get rid of this tipples on the volume?

Hi,
I downloaded the code from here->medicalDemo4 and modified a little.
The ripples(dont know how to name it) intensified but I dont know how to get rid of it.

动画

Here are what I modified.
from
vtkFixedPointVolumeRayCastMapper
to
vtkGPUVolumeRayCastMapper

from
vtkNew volumeScalarOpacity;
volumeScalarOpacity->AddPoint(0, 0.00);
volumeScalarOpacity->AddPoint(500, 0.15);
volumeScalarOpacity->AddPoint(1000, 0.15);
volumeScalarOpacity->AddPoint(1150, 0.85);

to
vtkNew volumeScalarOpacity;
volumeScalarOpacity->AddPoint(0, 0.00);
volumeScalarOpacity->AddPoint(99, 0);
volumeScalarOpacity->AddPoint(100, 0.7);
volumeScalarOpacity->AddPoint(2000, 1);

Thanks.

To remove wood grain artifacts you can:

  • enable jittering of the ray starting position: adds a subtle noise pattern but does not increase rendering time; or
  • reduce sampling distance: this removes the artifacts without adding a noise pattern, but slows down rendering; or
  • make the ramp in your scalar opacity transfer function a bit less steep: this blurs the boundary a bit, which is also helpful for reducing staircase artifacts (that occurs when volume spacing is anisotropic)

For such trivial bone visualization (when image quality is this good) you can also use surface rendering (get isosurface by flying edge filter and smooth using vtkWindowedSincPolyDataFilter). Surface rendering has a number of advantages: rendering time is negligible, you can display many structures, easily show/hide them, use advanced lighting (PBR), use GPU-based picking, etc.