module configuration error

After resolving misunderstandings about the module system , I made progress on building
my own module. However I have an error message that I’m struggling to understand.
When I run ccmake and configure I get

VTK::Interaction dependency is missing for Wrapping::Wrappable.

I’ve created my module by starting from the Wrappable example module.

Now, my vtk.module file includes VTK::Interaction and when I built VTK-9.1
I selected interaction components,
any suggestion on how to resolve the error?
[Icouldn’t spot how to attach a file to an issue r I’d include
my module .module and CMakeCache.

I’m on OSX 11.6

David Duke

The CMakeCache.txt probably wouldn’t be very informative, but could you post the contents of your vtk.module file (quoted with ``` ```) and the relevant pieces of your CMakeLists.txt files?

Perhaps the problem is just a typo. There is no VTK::Interaction module, you might have meant VTK::InteractionStyle or VTK::InteractionWidgets.

Using VTK::InteractionStyle and VTK::InteractionWidgets makes no difference.

I’ve attached the vtk.module to the email, if you need the contents inlined and quote please let me know.
AQlso included are the CMakeLists from the module root and the module-subdir.
If its easier I’ll just tarball the module and send that.


CMakeLists-9.1.txt (17.8 KB)

vtk.module (660 Bytes)

CMakeListsWrapping.txt (2.22 KB)

CMakeListsWrapping-module.txt (651 Bytes)

As in, you removed the non-existent VTK::Interaction module and added VTK::InteractionStyle and VTK::InteractionWidgets in its place? Again, I just want to be sure the problem isn’t being caused by a trivial mistake before I dig in any deeper.

Correct, I removed VTK::Interaction and then added the other two with the same result.

After removing VTK::Interaction, you are still seeing the following error when you configure with cmake?

VTK::Interaction dependency is missing for Wrapping::Wrappable.

I apologize if I sound like a broken record.

Yes withVTK::INTERACTION removed and replaced with theother two I get the same result:

CMake Error at /usr/local/lib/cmake/vtk-9.1/vtkModule.cmake:2518 (message):

The VTK::Interaction dependency is missing for Wrapping::Wrappable.

Call Stack (most recent call first):

CMakeLists.txt:57 (vtk_module_build)

Configuring incomplete, errors occurred!

See also “/Users/scsdjd/Visualisation/Wrap-9/CMakeFiles/CMakeOutput.log”.

See also “/Users/scsdjd/Visualisation/Wrap-9/CMakeFiles/CMakeError.log”.

Maybe you only removed VTK::Interaction from the DEPENDS section and not from PRIVATE_DEPENDS. In any case, the only reason for cmake to complain that it’s a missing dependency is if you list it as a dependency somewhere…

Face-palm! Thank you for spotting that, a different problem has popped up but I think Ican resolve then rty again with
the dependencies triple-checked.