ModuleNotFoundError: No module named 'vtkCommonKitPython'

Hello all,

On a windows 7 64 bits computer, I installed pyhton 3.7.1.
then in a command prompt I installed vtk with the command:

pip3 install vtk

This instaled vtk correctly as far as I can tell.
But then in python If I used the command:

>>> import vtk

I get an error ending by:

ModuleNotFoundError: No module named ‘vtkCommonKitPython’

So obviously nothing vtk related works on that computer. Other python modules work fine.

I checked the file was present at the adress indicated, it is there, exept the python error uses a path (…)\lib(…) instead of (…)\Lib(…)

Then I tried to rediefine environment variables PATH and PYTHONPATH, but it did not solve my problem.

A couple of month ago I installed python 3.7.1 and vtk on another windows 7 64 bits computer and it worked without problem so I am a bit surprised.

I would appreciate some help / ideas.
thank you,

Python gives that error if the module failed to be opened too. I’d check that dependent libraries (e.g., vtkCommonCore) is in PATH. Cc: @jcfr

The module vtkCommonKitPython can be found within the wheel:

After creating a virtual env and installing vtk wheel using Python 64-bit, I couldn’t reproduce the problem: