Slow clipping polydata

I’m using ActiViz and trying to clip polydata using scalars and it takes really very, very long time, more that 15min, I killed the process as it is not what expected.
Polydataset has ~7300 polylines and about 2,500,000 points, Tried both vtkTableBasedClipDataSet and vtkClipPolyData, no difference.
I imported the same data set in the Paraview (5.12) and it is the same, depending on the scalar value it can take from 1 minute to more than 10 minutes. The same when tried to clip with the plane.
Question is, is that expected or something else it going on.


My first reaction is that this is slower than expected. How “long” are the polylines, i.e., how many lines typically compose a single polyline? I’m wondering if using something like vtkTriangleFilter could be used to break up the polylines into separate lines, followed by clipping. I’m not sure this is the issue, but it’s worth a shot.

Also, is there any way you can share data?

Hi Will, thanks for you response

Each line can have max 999 vertices

Here is the link if you want to download the dataset
I’ll check triangle filter


I did a quick and dirty experiment and yes, I think the problem is the length of the polylines. Once you triangulate them, the number of lines is well over 2mil, and the clipping goes faster. I suspect that what is happening is that the polylines are being triangulated internally, and then clipped segment by line segment. I suspect this process is using a slow-path-based-abstract-API that has not been polished up. I suggest that you create an issue so we don’t forget…

Wow, that made big difference.
Thanks Will

When you said to create an issue, should I create the post in development or something else. Never did that before.


I believe the best way to do this is to goto Select New Issue and do your thing. I don’t do this that often so if there is a better way I hope someone corrects me…