transparent objects not rendered with vtk9 and mesa 18.3.4 & 20.1.8

I am trying to get VTK 9.0.1 to show transparent objects on our CentOS-7 with mesa but the transparent objects are not rendered at all apparently due to texture errors.

The attached script shows a red cube and a green sphere. Initially both are opaque. By pressing any key the green sphere is supposed to toggle between opaque and transparent. Instead the green sphere toggles between opaque and not rendered. An error trace (both for mesa 18.3.4 and 20.1.8) is attached too. I experienced similar problems already on VTK 8.2 (see issue 17456).

opaque_vtk901
transparent_vtk811 transparent_vtk901

Has anyone using mesa experienced similar problems, or used transparency successfully?

opacity.py (1.3 KB)
trace-mesa-18.3.4.out (8.4 KB)
trace-mesa-20.1.8.out (8.4 KB)

1 Like

Hello, I don’t know about mesa, but I detected some errors in texture in vtk9. Check my post if it can help you

If you define labels in a mask all the labels must be defined otherwise it fails. This is bug. But doing this, you can go around the problem.

Cheers

Thanks for your reply. Honestly I don’t understand how your post is related to textures, and also I am not using volume mapping but vtkPolyDataMapper and vtkCompositePolyDataMapper2 so the rendering passes are very much different I suppose. In vtk 8.1 the rendering of textures with mesa worked fine.

For what it’s worth I have this transparency problem too: Problem with transparency with VTK >= 8.0 on Linux . Opaque objects render fine but the moment that opacity is different from 1.0 they disappear. In my report I talked about Mesa versions and mine being possibly too old but it looks like you reproduced it with Mesa 20.1.8, so I don’t have any other leads at the moment, unfortunately.