vtk build issue in windows os

(Abhishek Venkataram) #1

Hi,

i was successfully able to build vtk with python wrappings on mac OS using the suggestion given by Dan Lipsa in using vtk 8.2.0 with python wrappings with anaconda, however when i try to follow the same procedure in windows os i am getting the error

basically there is no WrappingPythonCore -8.90.lib in the path

i have set the python path like in the image below and have selected the wrap python option,

even if is set the VTK_WrappingPythonCore to yes i still get the same error

Can anyone help me with building vtk for windows and anaconda please?

Thanks

(Abhishek Venkataram) #2

hi, sorry for bothering, i was able to fix the issue by setting the LIBPATH environment variable to the directory containing the python libpath

thanks

(Ben Boeckel) #3

CMake should be getting the path to the python36.lib file and passing it (that first error causes the second error since vtkWrappingPythonCore doesn’t get made). Does python36.lib show up in CMakeCache.txt at all?

(Abhishek Venkataram) #4

hi,
yes it does, but i think the permission issue was not letting the file to be read during build

(Ben Boeckel) #5

LIBPATH wouldn’t fix permission errors. I think this is more likely some #pragma asking to link python36.lib without extra information. Not sure why what CMake is generating with those cache isn’t working here without seeing the link link for WrappingPythonCore.