VTK installation in Anaconda python distribution

I have some problems when I try to install VTK python package in latest anaconda distribution (2021.5 python 3.8).

If I execute:

conda install -c conda-forge vtk

I only get error messages like:

Collecting package metadata (current_repodata.json): done
Solving environment: failed with initial frozen solve. Retrying with flexible solve.
Solving environment: failed with repodata from current_repodata.json, will retry with next repodata source.

Anaconda tries to install several times, but finally it does not work.

I have tried to install vtk python package both in a dedicated environment and in the base environment with same results. I also have uninstalled Anaconda python distribution and I tried to install vtk python package in a complete new Anaconda installation. I got the same errors in all the cases.

This is the first time I try to use VTK in python (I have been working with vtk library in C++ until now). I expected it to be easy to install, so I’m pretty surprised.
Please, could you tell me what I’m doing wrong?

Thanks !

PS. I can install other python libraries with a similar command (like OpenCV, or even pyTorch) without any problem.

Hmm. I’m not sure who maintains the Conda packaging stuff. @danlipsa or @amaclean, do you know?

I see in the list some CDAT contributors. Probably the best would be file a bug report for the recipe.

Yeah, I stopped using the conda install because it wasn’t working and use pip instead.

1 Like

It works perfectly with pip.
Thank you, Dave !

1 Like