vtkCollisionDetectionFilter

hi
i compiled vtk 8.2.0 with cmake and vs 2017 and i tested it.
but i can’t see vtkCollisionDetectionFilter.
is any special setings needed to compile vtk and use vtkCollisionDetectionFilter?
Thanks a lot.

Hello, Jaafar,

vtkCollisionDetectionFilter is not in 8.2.0. You have to get the latest unstable version of VTK from here: https://gitlab.kitware.com/vtk/vtk .

cheers,

Paulo

hi Paulo
thanks for your answer.

i downloaded vtk master an compiled it with vs 2015.

it includes VtkCollisionDetectionFilter but i need QT too.

i selected QT options in cmake but when i compile it i see an error in vs as:

Error

C2039

‘Frame’: is not a
member of ‘QGLWidget’

GUISupportQtOpenGL

C:\VTK\SOURCE\source\GUISupport\QtOpenGL\QVTKWidget2.cxx

488

how can i fix this error.
thanks

Hi Jaafar,

Enabling Qt is not enough. VTK will need Qt (.h, .lib and .dll) itself. You have to either obtain the Qt libraries precompiled with VS 2015 or compile them yourself.

regards,

Paulo

You are right , i installed QT5.14.1 (VS 2015 ) with QT offline installer before compiling , but that error occurred.

i used vtk-master, VS2015(update 1) , cmake 3.16.4 and
QT5.14.1 VS 2015 .

qt options:
VTK_BUILD_QT_DESIGNER_PLUGIN : checked

VTK_GROUP_ENABLE_Qt= yes

VTK_MODULE_ENABLE_VTK_GUISupportQt= want

VTK_MODULE_ENABLE_VTK_GUISupportQtOpenGL=want

VTK_MODULE_ENABLE_VTK_GUISupportQtSQL = want

VTK_MODULE_ENABLE_VTK_RenderingQt = want

VTK_MODULE_ENABLE_VTK_ViewsQt= want

Error C2039 ‘Frame’: is not a member of ‘QGLWidget’ GUISupportQtOpen

Well, since it is an unstable version of VTK, I recommend reporting an issue here: https://gitlab.kitware.com/vtk/vtk/issues stating the versions you’re using (Qt 5.14.1, VTK unstable, VS 2015, etc.).

FYI this error was corrected on master.

1 Like